Cara Yang Benar Memperbaiki Kali Linux Tidak Bisa Update SIGNATURES WERE INVALID: EXPKEYSIG

Tidak Bisa Update SIGNATURES WERE INVALID: EXPKEYSIG disebabkan karena adanya kesalahan pada koneksi ke repository kali linux ke server pusatnya. Hal ini bisa membuat kali linux tidak bisa melakukan apt-get update untuk mengupdate terminalnya. Sebenarnya ada cara yang mudah untuk mengatasi keasalah error SIGNATURES WERE INVALID: EXPKEYSIG saat akan melakukan update, yaitu dengan menginstal sistem kali linux ke versi terbaru. Memang kali linux versi terbaru itu banyak perubahan dan perintah di terminal juga banyak yang berubah, oleh sebab itu kali linux geresai lama memang terbaik karena tidak ribet.

Disamping ribetnya versi kali linux terbaru, ada beberapa manfaat yang bisa digunakan ketika kita mencoba mengoperasikan kali linux versi terbaru, diantaranya:

  • Alat atau Tools lebih baru
  • Mudah untuk mendapatkan update ke server Repository
  • Banyak bug yang diperbaiki

Disamping keunggulan menggunakan kali linux versi terbaru, tetapi ada juga kelemahan dan kekuranganya. Saya sendiri untuk menjebol password wifi pakai aircrack-ng lebih memilih menggunkan versi lama karena lebih akuratn perintah-perintahnya tidak begitu rumit dan lebih simpel saja.

Bagi kalian yang mrnggunakan kali linux versi lama dan tidak bisa melakan update dan mengalami masalah SIGNATURES WERE INVALID: EXPKEYSIG. Kalian bisa ikuti beberapa langkah berikut ini untuk memperbaiki masalah tidak bisa update kali linux.

Tutorial Mengatasi Kali Linux Tidak Bisa Update SIGNATURES WERE INVALID: EXPKEYSIG Terbaru

Ada beberapa langkah yang cepat dan mudah untuk mengatasi Tidak Bisa Update SIGNATURES WERE INVALID: EXPKEYSIG, berikut langkah-langkahnya:

1. Merubah Sources.list

  1. Pertama kalian cari letak sources.listnya dengan membuka terminal di kali linux. Ketikkan perintah berikut:
    locate sources.list
  2. Didalam terminal akan muncul beberapa letak atau lokasi sources.listnya yaitu di: /etc/apt/sources.list
  3. Jika sudah ketemu kalian ketikkan perintah:
    gedit /etc/apt/sources.list
  4. lalu hapus semua isi didalam text tersebut dan ganti dengan text dibawah ini: #see https://http.kali.org/docs/general-use/kali-linux-sources-list-repositories/ deb http://http.kali.org/kali kali-rolling main contrib non-free #additional line for sources packages deb-src http://http.kali.org/kali kali-rolling main contrib non-free
  5. kalian simpan dan kembali ke Terminal
signatures were invalid: expkeysig

2. Menambahkan Signature Manual

  1. langkah berikutnya ketikkan perintah: gpg --keyserver keyserver.ubuntu.com --recv-key 7D8D0BF6
    gpg -a --export 7D8D0BF6 | apt-key add -
signatures were invalid: expkeysig

3. Melakukan Manual Update

Pada tahap terakhir ini, kita akan melakukan update manual, caranya: apt-get update

signatures were invalid: expkeysig

Oke sukses dan berhasil melakukan update secara manual dan masalah Tidak Bisa Update SIGNATURES WERE INVALID: EXPKEYSIG berhasil diperbaiki.

Jika masih belum jelas kalian bisa simak video berikut:

Itulah tadi beberapa langkah mudah dan cepat mengatasi tidak bisa update kali linux dikarenakan SIGNATURES WERE INVALID: EXP KEY SIG. Semoga bermanfaat

  • Masih berfungsi dan bekerja. Usahakan kalian memasukkan perintahnya dengan benar agar tidak terjadi kesalahan dalam melakukan update kali linux
  • Tidak, jika kalian ingin mendapatkan pembaruan Tools di kali linux saya sarankan untuk menginstal kali linux versi terbaru. Namun ada keuntungan sendiri menggunakan kali linux versi lama ini, yaitu toolnya terkadang lebih responsif dan mudah dioperasikan dari pada yang versi baru.
  • Tergantung dari Tools yang ingin kita gunakan, contoh saja John The Ripper di Kali linux versi lama lebih responsif dari pada kali linux terbaru karena untuk menjalankanya menggunakan perintah kode terbaru lagi.